summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorIvan Maidanski <ivmai@mail.ru>2017-02-20 11:10:07 +0300
committerIvan Maidanski <ivmai@mail.ru>2017-02-20 11:12:59 +0300
commit51ec3ca62f67ea7de3ec272334083c000d0ff774 (patch)
treeb68218b66dadb0c1864310f4cec4b0848f2be266 /Makefile.am
parent9764773521e000397c4754f69b19f5d9c630f3a2 (diff)
downloadlibatomic_ops-51ec3ca62f67ea7de3ec272334083c000d0ff774.tar.gz
Workaround 'AM_EXTRA_RECURSIVE_TARGETS not found in library' autoconf error
(fix commit 3b7e732) * Makefile.am (.PHONY): Add check-nolink, check-nolink-local targets. * Makefile.am (check-nolink): New target (which invokes existing check-nolink-local in this Makefile and in tests/Makefile). * configure.ac (AM_EXTRA_RECURSIVE_TARGETS): Remove (this directive is not supported by autoconf-1.12 and earlier).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ee74821..74a9b0d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,6 +10,13 @@ dist_pkgdata_DATA = COPYING README.md
EXTRA_DIST = autogen.sh
+# TODO: After migration to autoconf-1.13+, remove check-nolink definition
+# from this Makefile.am and add AM_EXTRA_RECURSIVE_TARGETS([check-nolink])
+# back to configure.ac file.
+.PHONY: check-nolink check-nolink-local
+check-nolink: check-nolink-local
+ $(MAKE) --directory tests $(AM_MAKEFLAGS) check-nolink-local
+
check-nolink-local: all
#distclean-local: