summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDodji Seketeli <dodji@gnome.org>2004-02-29 00:18:01 +0000
committerDodji Seketeli <dodji@src.gnome.org>2004-02-29 00:18:01 +0000
commita2baab08b9a693452eb6c99c4f7a713508df6c2e (patch)
tree8598532ab3ae18dbbfacba6997cc97c52d4397cc /src/Makefile.am
parentbc9967a6c28413922ad7055fa8257dbbfb6ba8f3 (diff)
downloadlibcroco-a2baab08b9a693452eb6c99c4f7a713508df6c2e.tar.gz
Created this new CRPropList class. added this new helper function.
2004-02-29 Dodji Seketeli <dodji@gnome.org> * src/cr-prop-list.[ch], src/Makefile.am,src/libcroco.h: Created this new CRPropList class. * src/cr-sel-eng.c: (put_css_properties_in_props_list): added this new helper function. (cr_sel_eng_get_matched_properties_from_cascade): Created a new version of this function to make it use the new CRPropList instead of a hashtable. Putting properties/declaration in a hashtable make us loose the "order" in which declarations are present in the ruleset. That's why I use a CRPropList instead. * src/cr-style.c: (cr_style_set_style_from_decl): fix a silly error that make border-right and border-top switch.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5b82d21..ee4d2c9 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -24,6 +24,7 @@ cr-utils.h \
cr-fonts.h \
cr-sel-eng.h \
cr-style.h \
+cr-prop-list.h \
libcroco-config.h
@@ -74,7 +75,9 @@ cr-style.h \
cr-sel-eng.c \
cr-sel-eng.h \
cr-fonts.c \
-cr-fonts.h
+cr-fonts.h \
+cr-prop-list.c \
+cr-prop-list.h
lib_LTLIBRARIES=libcroco.la
libcroco_la_SOURCES= $(SRCS)