summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2013-12-16 08:25:12 -0800
committerEric Anholt <eric@anholt.net>2013-12-16 08:27:55 -0800
commitc92fcc852fe123034633eba9cda91c780632b2f8 (patch)
tree274789dd6f108b90fe0b27556c6e95996104ce20 /configure.ac
parentc24afd8a9e5621638bc86e9013df49c8caa593d8 (diff)
downloadlibepoxy-c92fcc852fe123034633eba9cda91c780632b2f8.tar.gz
Fix testsuite build on OS X.
There's no linker flag of this name in the normal clang, presumably beause the linker feature doesn't exist.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f1d2b0f..fd390de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -52,6 +52,8 @@ AC_SYS_LARGEFILE
# uintptr_t to a void *") by default. Kill that.
XORG_TESTSET_CFLAG(CWARNFLAGS, [-Wno-int-conversion])
+has_znow=yes
+
case $host_os in
mingw*)
build_egl=no
@@ -72,6 +74,7 @@ case $host_os in
build_egl=no
build_glx=yes
build_wgl=no
+ has_znow=no
EPOXY_LINK_LIBS=""
;;
*)
@@ -101,6 +104,7 @@ if test x$build_wgl = xyes; then
AC_DEFINE([BUILD_WGL], [1], [build WGL tests])
fi
+AM_CONDITIONAL(HAS_ZNOW, test x$has_znow = xyes)
case $host_os in
mingw*)