summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2014-02-06 10:51:33 -0800
committerEric Anholt <eric@anholt.net>2014-02-06 11:16:18 -0800
commite4f5da9539f606e0043678579de83f66f0b3e9c4 (patch)
tree19cd4175f07e0213617fb7b1a9a1479a1008d038 /configure.ac
parentc99653408057065d5a3adb443dc9ba5420de0219 (diff)
downloadlibepoxy-e4f5da9539f606e0043678579de83f66f0b3e9c4.tar.gz
Add a test that khrplatform.h (if present) agrees with us.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3037c76..35b357d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -48,6 +48,12 @@ AC_LIBTOOL_WIN32_DLL
AC_PROG_LIBTOOL
AC_SYS_LARGEFILE
+AC_CHECK_HEADER([KHR/khrplatform.h],
+ [AC_DEFINE([HAVE_KHRPLATFORM_H], [1],
+ [Define to 1 if you have <KHR/khrplatform.h> (used for tests)]
+ )]
+ )
+
# OS X defaults to having -Wint-conversion ("warn when passing
# uintptr_t to a void *") by default. Kill that.
XORG_TESTSET_CFLAG(CWARNFLAGS, [-Wno-int-conversion])