summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2017-02-13 09:26:57 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2017-02-15 14:09:01 +0000
commit89f9aa044fbca703670cbaa037716112c7f7fefb (patch)
treeeff06351db13c28bdec6a9160f10eb0e28b121b8 /meson.build
parentb5d921ae4569d39e10199e25a487bd8a23edd750 (diff)
downloadlibepoxy-89f9aa044fbca703670cbaa037716112c7f7fefb.tar.gz
Remove the shebang from gen_dispatch.py
Instead of having Meson determine the invocator through the shebang line we explicitly pass the script file to the Python interpreter. This will allow us to either use Python3 or Python2, or whatever Python.exe is available on Windows.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 9651a6c..70c417d 100644
--- a/meson.build
+++ b/meson.build
@@ -202,8 +202,11 @@ configure_file(input: 'epoxy.pc.in',
install: true,
install_dir: join_paths(epoxy_libdir, 'pkgconfig'))
+# Python
+python = find_program('python', required: true)
+
# Generates the dispatch tables
-gen_dispatch_py = find_program('src/gen_dispatch.py')
+gen_dispatch_py = join_paths(meson.source_root(), 'src/gen_dispatch.py')
gl_registry = files('registry/gl.xml')
egl_registry = files('registry/egl.xml')