summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index ea2b354..85e73d6 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -152,3 +152,26 @@ if build_wgl
test(test_name, test_bin)
endforeach
endif
+
+# Apple
+if host_machine.system().contains('darwin')
+ opengl_dep = dependency('appleframeworks', modules: ['OpenGL', 'Carbon'], required: true)
+
+ cgl_tests = [
+ [ 'cgl_core', [ 'cgl_core.c' ] ],
+ ]
+
+ foreach t: cgl_tests
+ test_name = t[0]
+ test_sources = t[1]
+
+ test(test_name,
+ executable(
+ test_name, test_sources,
+ c_args: test_cflags,
+ include_directories: libepoxy_inc,
+ dependencies: [ libepoxy_dep, opengl_dep ],
+ ),
+ )
+ endforeach
+endif