summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Lambert <eric_lambert@xyratex.com>2014-06-11 16:07:04 -0700
committerEric Lambert <eric_lambert@xyratex.com>2014-06-11 16:07:04 -0700
commit9e9e2a6ec3711937cf1066bedf416304e9c4b891 (patch)
treedc0df15c5da71c3115e5934aba9c3318a2fb3e77 /configure.ac
parent727eb99a3cb63b91a820f27132f2321377ba79a6 (diff)
downloadliberasurecode-9e9e2a6ec3711937cf1066bedf416304e9c4b891.tar.gz
refactor workspace and build
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 14 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 2da973e..844022f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,11 +5,10 @@ AC_INIT(erasurecode,0.1)
AC_PREREQ([2.61])
-AM_INIT_AUTOMAKE(no-dependencies)
+AM_INIT_AUTOMAKE([subdir-objects no-dependencies])
LT_INIT # libtool
-AC_CONFIG_SRCDIR(xor_codes)
-AC_CONFIG_SRCDIR(alg_sig)
+AC_CONFIG_SRCDIR(src)
AC_CONFIG_HEADER(include/config.h)
dnl Needed when reconfiguring with 'autoreconf -i -s'
@@ -39,4 +38,15 @@ AC_CHECK_LIB([gf_complete], [gf_init_easy], [],
AX_EXT()
-AC_OUTPUT(Makefile xor_codes/Makefile alg_sig/Makefile)
+AC_ARG_ENABLE(debug,
+AS_HELP_STRING([--enable-debug],
+ [enable debugging, default: no]),
+[case "${enableval}" in
+ yes) debug=true ;;
+ no) debug=false ;;
+ *) AC_MSG_ERROR([bad value ${enableval} for --enable-debug]) ;;
+esac],
+[debug=false])
+AM_CONDITIONAL(DEBUG, test x"$debug" = x"true")
+AC_OUTPUT(Makefile)
+