summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTushar Gohad <tushar.gohad@intel.com>2014-07-13 19:22:48 -0700
committerTushar Gohad <tushar.gohad@intel.com>2014-07-13 19:26:23 -0700
commit6533759ba5060149886ed0a88ba8c9373f7bcdd7 (patch)
tree67aa2aee468d56e8d70ef3b8390ea985dea2f717 /src/Makefile.am
parent06e221f6708d5515296801af2ae14d6ea33e837e (diff)
downloadliberasurecode-6533759ba5060149886ed0a88ba8c9373f7bcdd7.tar.gz
Frontend/backend API split, make EC handle int type
.. also introduce a map for backend method stub name to backend library function names Signed-off-by: Tushar Gohad <tushar.gohad@intel.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 780db29..43ff2be 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -14,8 +14,9 @@ liberasurecode_la_SOURCES = \
utils/chksum/galois.c \
backends/xor/flat_xor_3.c
+liberasurecode_la_CPPFLAGS = -Werror
liberasurecode_la_LIBADD = \
- builtin/xor_codes/libXorcode.la -lgf_complete
+ builtin/xor_codes/libXorcode.la -lgf_complete -lpthread
# Version format (C - A).(A).(R) for C:R:A input
liberasurecode_la_LDFLAGS = -rpath '$(libdir)' -version-info 9:4:9