summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e5ae47a..8daa3b3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,6 +18,7 @@ thisinclude_HEADERS = \
include/erasurecode/erasurecode.h \
include/erasurecode/erasurecode_backend.h \
include/erasurecode/erasurecode_helpers.h \
+ include/erasurecode/erasurecode_helpers_ext.h \
include/erasurecode/erasurecode_log.h \
include/erasurecode/erasurecode_preprocessing.h \
include/erasurecode/erasurecode_postprocessing.h \
@@ -30,6 +31,17 @@ thisinclude_HEADERS = \
include/rs_vand/rs_galois.h \
include/rs_vand/liberasurecode_rs_vand.h
+install-exec-hook:
+ -(cd $(DESTDIR)$(includedir) && \
+ rm -f erasurecode.h erasurecode_version.h \
+ erasurecode_stdinc.h erasurecode_helpers.h \
+ config_liberasurecode.h && \
+ $(LN_S) liberasurecode/erasurecode.h && \
+ $(LN_S) liberasurecode/erasurecode_version.h && \
+ $(LN_S) liberasurecode/erasurecode_stdinc.h && \
+ $(LN_S) liberasurecode/erasurecode_helpers.h && \
+ $(LN_S) liberasurecode/config_liberasurecode.h)
+
test: check
$(eval SONAMES := $(shell find $(abs_top_builddir) -name '*.so'))
$(eval SODIRS := $(dir $(SONAMES)))