summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2013-07-29 13:50:41 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2013-08-29 13:54:49 +1000
commitcc2eaec4ed40e1776eff005499f5a22a253d8f1a (patch)
treef172430f7edfbee4e607d78f8e59207b4c73f705 /configure.ac
parent21356cca571dc6222a78494b0ddd9b5bf745395e (diff)
downloadlibevdev-cc2eaec4ed40e1776eff005499f5a22a253d8f1a.tar.gz
test: switch udev backend over to new libevdev-uinput bits
Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d92aba1..f3a0bf8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,10 +35,11 @@ LT_INIT
PKG_PROG_PKG_CONFIG()
PKG_CHECK_MODULES(CHECK, [check], [HAVE_CHECK="yes"], [HAVE_CHECK="no"])
if test "x$HAVE_CHECK" != "xyes"; then
- AC_MSG_WARN([check not found - skipping building unit tests])
+ AC_MSG_WARN([check not found - skipping building unit tests])
fi
AM_CONDITIONAL(BUILD_TESTS, [test "x$HAVE_CHECK" = "xyes"])
+
if test "x$GCC" = "xyes"; then
GCC_CFLAGS="-Wall -Wextra -Wno-unused-parameter -g -Wstrict-prototypes -Wmissing-prototypes -fvisibility=hidden"
fi