summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2020-02-18 19:31:43 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2020-02-19 08:34:55 +1000
commitd7098601c867b35ec16e133f2b5e50a27c0b3354 (patch)
treef5c535b13dcceef3e42f8a363a6e03d1ba9b8afa /meson.build
parentd654a8edf8070e21c1634809a4108e663eb4a16d (diff)
downloadlibevdev-d7098601c867b35ec16e133f2b5e50a27c0b3354.tar.gz
meson.build: hook up the static symbols leak test
And because bash on F31 is leaking, we need an extra valgrind suppression. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 6a1e94d..a9dc555 100644
--- a/meson.build
+++ b/meson.build
@@ -190,6 +190,7 @@ if dep_check.found()
valgrind_env = environment()
valgrind_env.set('CK_TIMEOUT_MULTIPLIER', '10')
valgrind_env.set('CK_FORK', 'no')
+ valgrind_env.set('RUNNING_ON_VALGRIND', '1')
valgrind_suppressions_file = join_paths(dir_src_test, 'valgrind.suppressions')
add_test_setup('valgrind',
exe_wrapper: [ valgrind,
@@ -203,7 +204,9 @@ if dep_check.found()
message('valgrind not found, disabling valgrind test suite')
endif
- # FIXME: static link test
+ test_static_link = find_program('test/test-static-symbols-leak.sh')
+ test('static-symbols-leak', test_static_link,
+ args: [meson.current_build_dir()])
endif
doxygen = find_program('doxygen', required: get_option('documentation'))