summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 3e81169..fe5cfa9 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,5 +1,5 @@
if BUILD_TESTS
-run_tests = test-libevdev
+run_tests = test-libevdev test-kernel
build_tests = test-compile-pedantic test-link
noinst_PROGRAMS = $(run_tests) $(build_tests)
@@ -43,6 +43,14 @@ test_link_SOURCES = test-link.c
test_link_CFLAGS = -I$(top_srcdir)
test_link_LDADD = $(top_builddir)/libevdev/libevdev.la
+test_kernel_SOURCES = \
+ test-kernel.c \
+ $(common_sources)
+test_kernel_CFLAGS = -I$(top_srcdir)
+test_kernel_LDADD = \
+ $(CHECK_LIBS) \
+ $(top_builddir)/libevdev/libevdev.la
+
if GCOV_ENABLED
CLEANFILES = gcov-report.txt