summaryrefslogtreecommitdiff
path: root/expat/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastian Pipping <sebastian@pipping.org>2021-06-23 20:23:09 +0200
committerSebastian Pipping <sebastian@pipping.org>2021-07-06 16:22:38 +0200
commit7cf97a9bda1b67cd2adba6d972b693aff0d8b875 (patch)
tree69e9e9f3211c2a99e0507af3b81414da41548eda /expat/CMakeLists.txt
parentb73c80a727feee73843221a13c816334d8ab2ba6 (diff)
downloadlibexpat-git-7cf97a9bda1b67cd2adba6d972b693aff0d8b875.tar.gz
CMake: Apply -DEXPAT_MSVC_STATIC_CRT=ON to off-grid built types
Diffstat (limited to 'expat/CMakeLists.txt')
-rw-r--r--expat/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/expat/CMakeLists.txt b/expat/CMakeLists.txt
index fcd0c39a..c6b0172f 100644
--- a/expat/CMakeLists.txt
+++ b/expat/CMakeLists.txt
@@ -306,10 +306,12 @@ if (MSVC)
if (EXPAT_MSVC_STATIC_CRT)
message("-- Using static CRT ${EXPAT_MSVC_STATIC_CRT}")
foreach(flag_var
+ CMAKE_CXX_FLAGS_${_EXPAT_BUILD_TYPE_UPPER}
CMAKE_CXX_FLAGS_DEBUG
CMAKE_CXX_FLAGS_RELEASE
CMAKE_CXX_FLAGS_MINSIZEREL
CMAKE_CXX_FLAGS_RELWITHDEBINFO
+ CMAKE_C_FLAGS_${_EXPAT_BUILD_TYPE_UPPER}
CMAKE_C_FLAGS_DEBUG
CMAKE_C_FLAGS_RELEASE
CMAKE_C_FLAGS_MINSIZEREL