summaryrefslogtreecommitdiff
path: root/expat/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastian Pipping <sebastian@pipping.org>2021-06-05 17:12:02 +0200
committerSebastian Pipping <sebastian@pipping.org>2021-07-06 16:22:38 +0200
commitb73c80a727feee73843221a13c816334d8ab2ba6 (patch)
tree5bd6e7826ab3ac06ca4826c8448ddfbceed4bd7e /expat/CMakeLists.txt
parenta3bc9162e6b4b1bd79ac11b2d9f15066261c0540 (diff)
downloadlibexpat-git-b73c80a727feee73843221a13c816334d8ab2ba6.tar.gz
CMake: Avoid empty CMAKE_BUILD_TYPE
Diffstat (limited to 'expat/CMakeLists.txt')
-rw-r--r--expat/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/expat/CMakeLists.txt b/expat/CMakeLists.txt
index 78718a63..fcd0c39a 100644
--- a/expat/CMakeLists.txt
+++ b/expat/CMakeLists.txt
@@ -106,6 +106,9 @@ if(DEFINED BUILD_SHARED_LIBS)
else()
set(_EXPAT_SHARED_LIBS_DEFAULT ON)
endif()
+if(NOT CMAKE_BUILD_TYPE)
+ set(CMAKE_BUILD_TYPE NoConfig) # so that accessing CMAKE_*_POSTFIX will be waterproof
+endif()
string(TOUPPER "${CMAKE_BUILD_TYPE}" _EXPAT_BUILD_TYPE_UPPER)
#