summaryrefslogtreecommitdiff
path: root/expat/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'expat/CMakeLists.txt')
-rw-r--r--expat/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/expat/CMakeLists.txt b/expat/CMakeLists.txt
index bccda81c..11797a5c 100644
--- a/expat/CMakeLists.txt
+++ b/expat/CMakeLists.txt
@@ -401,7 +401,10 @@ if(WIN32 AND NOT MINGW)
# NOTE: This avoids a name collision with Expat.dll of Perl's XML::Parser::Expat
# on Windows by resorting to filename libexpat.dll since Expat 1.95.3.
# Everything but MSVC is already adding prefix "lib", automatically.
- set_property(TARGET expat PROPERTY PREFIX lib)
+ # NOTE: "set_property(TARGET expat PROPERTY PREFIX lib)" would only affect *.dll
+ # files but not *.lib files, so we have to rely on propert OUTPUT_NAME, instead.
+ # Property CMAKE_*_POSTFIX still applies.
+ set_property(TARGET expat PROPERTY OUTPUT_NAME libexpat)
endif()
target_include_directories(expat