summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 5712edd..20fa382 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,6 +5,14 @@ AUTOMAKE_OPTIONS = foreign subdir-objects
ACLOCAL_AMFLAGS = -I m4
SUBDIRS = include testsuite man
+if BUILD_DOCS
+## This hack is needed because it doesn't seem possible to make a
+## conditional info_TEXINFOS in Automake. At least Automake 1.14
+## either gives errors -- if this attempted in the most
+## straightforward way -- or simply unconditionally tries to build the
+## info file.
+SUBDIRS += doc
+endif
EXTRA_DIST = LICENSE ChangeLog.v1 ChangeLog.libgcj \
ChangeLog.libffi ChangeLog.libffi-3.1 \
@@ -16,11 +24,6 @@ EXTRA_DIST = LICENSE ChangeLog.v1 ChangeLog.libgcj \
libtool-ldflags
-info_TEXINFOS =
-if BUILD_DOCS
-#info_TEXINFOS += doc/libffi.texi
-endif
-
## ################################################################
##