summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNIIBE Yutaka <gniibe@fsij.org>2018-10-16 14:46:55 +0900
committerNIIBE Yutaka <gniibe@fsij.org>2018-10-16 14:46:55 +0900
commit0f2c6ce2c9504c6df435463243edaa669e57b109 (patch)
tree0a004a1b3067c1c5bd7f68b4fe706ff616387cdb /Makefile.am
parent86e5e06a97ae13b8bbf6923ecc76e02b9c429b46 (diff)
downloadlibgcrypt-0f2c6ce2c9504c6df435463243edaa669e57b109.tar.gz
build: Let configure create the VERSION file.
* autogen.sh: Update from libgpg-error. * configure.ac: Use mym4_versoin to create VERSION file. * Makefile.am (dist-hook): Do not create VERSION file. (EXTRA_DIST): Add VERSION. -- GnuPG-bug-id: 3283 Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 2 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index f97af7fb..21e91acf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -38,14 +38,12 @@ EXTRA_DIST = autogen.sh autogen.rc README.GIT LICENSES \
ChangeLog-2011 build-aux/ChangeLog-2011 doc/ChangeLog-2011 \
m4/ChangeLog-2011 cipher/ChangeLog-2011 src/ChangeLog-2011 \
random/ChangeLog-2011 tests/ChangeLog-2011 mpi/ChangeLog-2011 \
- build-aux/git-log-footer build-aux/git-log-fix
+ build-aux/git-log-footer build-aux/git-log-fix VERSION
DISTCLEANFILES =
-# Add all the files listed in "distfiles" files to the distribution,
-# apply version number s to some files and create a VERSION file which
-# we need for the Prereq: patch file trick.
+# Add all the files listed in "distfiles" files to the distribution
dist-hook: gen-ChangeLog
@set -e; \
for file in `cd $(top_srcdir); \
@@ -56,8 +54,6 @@ dist-hook: gen-ChangeLog
|| cp -p $(top_srcdir)/$$dir/$$i $(distdir)/$$dir/$$i; \
done ; \
done
- @set -e; \
- echo "$(VERSION)" > $(distdir)/VERSION
distcheck-hook:
set -e; ( \