summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b13767d..57cd95d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,6 +20,7 @@ OPTION(ENABLE_FREETYPE "Enable Freetype2 support" 0)
OPTION(ENABLE_FONTCONFIG "Enable FontConfig support" 0)
OPTION(ENABLE_WEBP "Enable WebP support" 0)
OPTION(ENABLE_HEIF "Enable HEIF support" 0)
+OPTION(ENABLE_AVIF "Enable AVIF support" 0)
OPTION(ENABLE_RAQM "Enable RAQM support" 0)
if (BUILD_TEST)
@@ -124,6 +125,13 @@ else (USE_EXT_GD)
FIND_PACKAGE(HEIF REQUIRED)
ENDIF (ENABLE_HEIF)
+ IF (ENABLE_AVIF)
+ FIND_PACKAGE(libavif 0.8.2 REQUIRED CONFIG)
+ SET(HAVE_LIBAVIF 1)
+ SET(AVIF_LIBRARIES avif)
+ SET(AVIF_FOUND 1)
+ ENDIF (ENABLE_AVIF)
+
IF (ENABLE_LIQ)
FIND_PACKAGE(LIQ REQUIRED)
ENDIF (ENABLE_LIQ)