summaryrefslogtreecommitdiff
path: root/tests/gdtest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/gdtest/CMakeLists.txt')
-rw-r--r--tests/gdtest/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/gdtest/CMakeLists.txt b/tests/gdtest/CMakeLists.txt
index 4b05262..ff9fd7d 100644
--- a/tests/gdtest/CMakeLists.txt
+++ b/tests/gdtest/CMakeLists.txt
@@ -1,3 +1,7 @@
add_definitions(-DGDTEST_TOP_DIR="${CMAKE_CURRENT_SOURCE_DIR}/..")
-add_library (gdTest STATIC gdtest.c)
+SET(GDTEST_FILES gdtest.c)
+if(WIN32)
+ LIST(APPEND GDTEST_FILES readdir.c)
+endif()
+add_library(gdTest STATIC ${GDTEST_FILES})
target_link_libraries(gdTest ${GD_LIB})