summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPhilip Withnall <philip@tecnocode.co.uk>2015-04-19 20:43:17 +0100
committerPhilip Withnall <philip@tecnocode.co.uk>2015-04-22 00:52:45 +0100
commit727c13a632fbc6a9fd60d9b66921e12b618b55f5 (patch)
tree68c68a2ebaa3ae9b692c2a1f05ee5a3c3935dbb3 /Makefile.am
parent4cf196ef256c2869a35bfdd086e2fdf0ee1da64e (diff)
downloadlibgdata-727c13a632fbc6a9fd60d9b66921e12b618b55f5.tar.gz
youtube: Port to the YouTube API version 3
Deprecated API: • GDataYouTubeQuery:format, gdata_youtube_query_get_format(), gdata_youtube_query_set_format() • GDataYouTubeQuery:has-location • GDataYouTubeQuery:language, gdata_youtube_query_get_language(), gdata_youtube_query_set_language() • GDataYouTubeQuery:sort-order, gdata_youtube_query_get_sort_order(), gdata_youtube_query_set_sort_order() • GDataYouTubeQuery:uploader, gdata_youtube_query_get_uploader(), gdata_youtube_query_set_uploader() • GDataYouTubeSortOrder • GDataYouTubeUploader • GDataYouTubeContent • GDataYouTubeFormat • GDataYouTubeVideo:video-id, gdata_youtube_video_get_video_id() • gdata_youtube_video_look_up_content() (use gdata_youtube_video_get_player_uri() instead) • GDATA_YOUTUBE_RATING_TYPE_SIMPLE • GDataYouTubeCredit, GDATA_YOUTUBE_CREDIT_ENTITY_PARTNER • GDataYouTubeVideo:credit, gdata_youtube_video_get_credit() • GDataYouTubeVideo:is-draft, gdata_youtube_video_is_draft(), gdata_youtube_video_set_is_draft() • GDATA_YOUTUBE_*_FEED except GDATA_YOUTUBE_MOST_POPULAR_FEED (all others have been deprecated online and will transparently return the most popular videos from the past 24 hours) API changes: • GDataYouTubeQuery:restriction no longer accepts IP addresses • All GDataCommentable functionality on GDataYouTubeVideo is disabled at runtime until the v3 YouTube API for comments is finished online • Not all properties of a GDataYouTubeVideo may be retrieved when doing searches, retrieving related videos, or listing standard feeds — to guarantee getting all properties, use gdata_service_query_single_entry() for the video in question; common properties such as title, description, player URI and thumbnails will always be retrieved Internally, the GDataYouTubeControl and GDataYouTubeGroup APIs have been removed, but they were never visible publicly, so this is not an API break. Due to the transition from v2 to v3 of the YouTube API, your client’s developer key may stop working. Refresh it here: https://developers.google.com/youtube/registering_an_application https://bugzilla.gnome.org/show_bug.cgi?id=687597
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 0 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 1e1e0096..34c9539c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -323,9 +323,6 @@ gdata_youtube_headers = \
gdata/services/youtube/gdata-youtube-category.h \
gdata/services/youtube/gdata-youtube-comment.h \
gdata/services/youtube/gdata-youtube-feed.h
-private_headers += \
- gdata/services/youtube/gdata-youtube-group.h \
- gdata/services/youtube/gdata-youtube-control.h
gdatayoutubeinclude_HEADERS = \
$(gdata_youtube_headers) \
gdata/services/youtube/gdata-youtube-enums.h
@@ -449,9 +446,7 @@ gdata_sources = \
gdata/services/youtube/gdata-youtube-content.c \
gdata/services/youtube/gdata-youtube-credit.c \
gdata/services/youtube/gdata-youtube-query.c \
- gdata/services/youtube/gdata-youtube-group.c \
gdata/services/youtube/gdata-youtube-state.c \
- gdata/services/youtube/gdata-youtube-control.c \
gdata/services/youtube/gdata-youtube-category.c \
gdata/services/youtube/gdata-youtube-comment.c \
gdata/services/youtube/gdata-youtube-feed.c \