summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVicent Martí <tanoku@gmail.com>2011-09-22 10:17:43 -0700
committerVicent Martí <tanoku@gmail.com>2011-09-22 10:17:43 -0700
commit8114ee4c950d035388f1191081fbe77d9a9f3017 (patch)
treea1cfd43c33d8c8d56bf23d91f24bd5bb9840f24e /CMakeLists.txt
parente1b86444676b70154bf8ab450d429bdef57a8276 (diff)
parent4ee8418a0877d1c2f48459bb266342b127fc7d87 (diff)
downloadlibgit2-8114ee4c950d035388f1191081fbe77d9a9f3017.tar.gz
Merge pull request #405 from carlosmn/http-ls
Implement ls-remote over HTTP
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 61eb799a8..448a88b9c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,7 +22,10 @@ STRING(REGEX REPLACE "^.*LIBGIT2_VERSION \"[0-9]+\\.[0-9]+\\.([0-9]+).*$" "\\1"
SET(LIBGIT2_VERSION_STRING "${LIBGIT2_VERSION_MAJOR}.${LIBGIT2_VERSION_MINOR}.${LIBGIT2_VERSION_REV}")
# Find required dependencies
-INCLUDE_DIRECTORIES(src include)
+INCLUDE_DIRECTORIES(src include deps/http-parser)
+
+FILE(GLOB SRC_HTTP deps/http-parser/*.c)
+
IF (NOT WIN32)
FIND_PACKAGE(ZLIB)
ENDIF()
@@ -91,7 +94,7 @@ ELSE()
ENDIF ()
# Compile and link libgit2
-ADD_LIBRARY(git2 ${SRC} ${SRC_ZLIB})
+ADD_LIBRARY(git2 ${SRC} ${SRC_ZLIB} ${SRC_HTTP})
IF (WIN32)
TARGET_LINK_LIBRARIES(git2 ws2_32)
@@ -122,7 +125,7 @@ IF (BUILD_TESTS)
INCLUDE_DIRECTORIES(tests)
FILE(GLOB SRC_TEST tests/t??-*.c)
- ADD_EXECUTABLE(libgit2_test tests/test_main.c tests/test_lib.c tests/test_helpers.c ${SRC} ${SRC_TEST} ${SRC_ZLIB})
+ ADD_EXECUTABLE(libgit2_test tests/test_main.c tests/test_lib.c tests/test_helpers.c ${SRC} ${SRC_TEST} ${SRC_ZLIB} ${SRC_HTTP})
TARGET_LINK_LIBRARIES(libgit2_test ${CMAKE_THREAD_LIBS_INIT})
IF (WIN32)
TARGET_LINK_LIBRARIES(libgit2_test ws2_32)