summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKrzysztof Adamski <k@japko.eu>2013-09-01 18:59:42 +0200
committerKrzysztof Adamski <k@japko.eu>2013-09-01 19:00:16 +0200
commit5c37f00505bf00c14468813d94df69f3387f15b3 (patch)
treec9c90f972cf20181e61fdaee415288dc563dccaa /CMakeLists.txt
parent255836ddac05418f6bb2d68d27f5ff290669e2a9 (diff)
downloadlibgit2-5c37f00505bf00c14468813d94df69f3387f15b3.tar.gz
Build all example files if BUILD_EXAMPLES used.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1c70ec2d6..317ed1bee 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -426,4 +426,19 @@ IF (BUILD_EXAMPLES)
ADD_EXECUTABLE(git-rev-list examples/rev-list.c)
TARGET_LINK_LIBRARIES(git-rev-list git2)
+
+ ADD_EXECUTABLE(git-rev-parse examples/rev-parse.c)
+ TARGET_LINK_LIBRARIES(git-rev-parse git2)
+
+ ADD_EXECUTABLE(git-log examples/log.c)
+ TARGET_LINK_LIBRARIES(git-log git2)
+
+ ADD_EXECUTABLE(git-status examples/status.c)
+ TARGET_LINK_LIBRARIES(git-status git2)
+
+ ADD_EXECUTABLE(git-init examples/init.c)
+ TARGET_LINK_LIBRARIES(git-init git2)
+
+ ADD_EXECUTABLE(git-cat-file examples/cat-file.c)
+ TARGET_LINK_LIBRARIES(git-cat-file git2)
ENDIF ()