summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCarlos Martín Nieto <carlos@cmartin.tk>2011-07-06 09:11:03 +0200
committerCarlos Martín Nieto <carlos@cmartin.tk>2011-07-06 12:48:23 +0200
commit39cdf2728052a0817c12ec4348eef2c5d0825661 (patch)
tree35cff60355ded2d4b07de8d94c6b3cba1ce1ac0a /CMakeLists.txt
parente1bf24c86221fb412df52340ef2faa65c816c7bf (diff)
downloadlibgit2-39cdf2728052a0817c12ec4348eef2c5d0825661.tar.gz
Fix network MSYS compilation
MSYS/MinGW uses winsock but obviously doesn't set _MSC_VER. Use _WIN32 to decide whether to use winsock or BSD headers. Also remove these headers from src/transport_git.c altogether, as they are not needed. MSYS is very conservative, so we have to tell it that we don't care about versions of Windows lower than WindowsXP. We also need to tell CMake to add ws2_32 to the libraries list and we shouldn't add the -fPIC option, to MSYS because it complains that it does it anyway. Signed-off-by: Carlos Martín Nieto <carlos@cmartin.tk>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 82208dc12..26f00c728 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -53,7 +53,10 @@ IF (MSVC)
SET(CMAKE_C_FLAGS_DEBUG "/Od /DEBUG /MTd")
SET(CMAKE_C_FLAGS_RELEASE "/MT /O2")
ELSE ()
- SET(CMAKE_C_FLAGS "-Wall -Wextra -fPIC")
+ SET(CMAKE_C_FLAGS "-Wall -Wextra")
+ IF (NOT MINGW) # MinGW always does PIC and complains if we tell it to
+ SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIC")
+ ENDIF ()
SET(CMAKE_C_FLAGS_DEBUG "-g -O0")
SET(CMAKE_C_FLAGS_RELEASE "-O2")
ENDIF()
@@ -86,6 +89,11 @@ ENDIF ()
# Compile and link libgit2
ADD_LIBRARY(git2 ${SRC} ${SRC_ZLIB})
+
+IF (WIN32)
+ TARGET_LINK_LIBRARIES(git2 ws2_32)
+ENDIF ()
+
TARGET_LINK_LIBRARIES(git2 ${CMAKE_THREAD_LIBS_INIT})
SET_TARGET_PROPERTIES(git2 PROPERTIES VERSION ${LIBGIT2_VERSION_STRING})
SET_TARGET_PROPERTIES(git2 PROPERTIES SOVERSION ${LIBGIT2_VERSION_MAJOR})