summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSascha Cunz <sascha.cunz@gmail.com>2014-01-30 03:01:46 +0000
committerSascha Cunz <sascha.cunz@gmail.com>2014-01-30 03:01:46 +0000
commit4bc94eb5f049d1d0fd23128b05bb0d65ffac84d9 (patch)
tree95e9315f2e8fa5c45da1a3ea7802949924975007 /CMakeLists.txt
parent6e0ff093fb955adeeeed5c83a0fafc568d4b8074 (diff)
downloadlibgit2-4bc94eb5f049d1d0fd23128b05bb0d65ffac84d9.tar.gz
We never search for libiconv via pkg-config
So we actually also never know that we can set a dependency on it in pkg-config. Instead always give it the -L and -l options.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4483be338..6f2a2bb82 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -203,11 +203,7 @@ ENDIF()
IF (ICONV_FOUND)
ADD_DEFINITIONS(-DGIT_USE_ICONV)
INCLUDE_DIRECTORIES(${ICONV_INCLUDE_DIR})
- IF(ICONV_LIBRARIES MATCHES "libiconv")
- SET(LIBGIT2_PC_LIBS "${LIBGIT2_PC_LIBS} ${ICONV_LIBRARIES}")
- ELSE()
- SET(LIBGIT2_PC_REQUIRES "${LIBGIT2_PC_REQUIRES} iconv")
- ENDIF()
+ SET(LIBGIT2_PC_LIBS "${LIBGIT2_PC_LIBS} ${ICONV_LIBRARIES}")
ENDIF()
# Platform specific compilation flags