summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPatrick Steinhardt <ps@pks.im>2018-10-05 10:31:53 +0200
committerPatrick Steinhardt <ps@pks.im>2018-10-05 10:31:53 +0200
commitaa0ae59a2a31dc0ee5cc987066903d135a5f9e79 (patch)
tree9111893cdd39b595bec469ab6f10fda324000394 /CMakeLists.txt
parentdbb4a5866fcbb121000a705e074f679445d6916b (diff)
downloadlibgit2-aa0ae59a2a31dc0ee5cc987066903d135a5f9e79.tar.gz
cmake: explicitly enable int-conversion warnings
While GCC enables int-conversion warnings by default, it will currently only warn about such errors even in case where "-DENABLE_WERROR=ON" has been passed to CMake. Explicitly enable int-conversion warnings by using our `ENABLE_WARNINGS` macro, which will automatically use "-Werror=int-conversions" in case it has been requested by the user.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 47b1cd187..7165cca6a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -233,6 +233,7 @@ ELSE ()
DISABLE_WARNINGS(unused-function)
ENABLE_WARNINGS(format)
ENABLE_WARNINGS(format-security)
+ ENABLE_WARNINGS(int-conversion)
IF (APPLE) # Apple deprecated OpenSSL
DISABLE_WARNINGS(deprecated-declarations)