summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEtienne Samson <samson.etienne@gmail.com>2018-08-17 15:56:30 +0000
committerEtienne Samson <samson.etienne@gmail.com>2018-08-24 22:00:05 +0200
commit1a9cc18260b68b149476adb6f39e37ab47d3d21f (patch)
tree532d1f75793b9fde27b1306c09e577ba16d0bc38 /CMakeLists.txt
parent8856337b35ad417db9fa5604f76086528cb0436b (diff)
downloadlibgit2-1a9cc18260b68b149476adb6f39e37ab47d3d21f.tar.gz
util: make the qsort_r check work on macOS
This performs a compile-check by using CMake support, to differentiate the GNU version from the BSD version of qsort_r. Module taken from 4f252abea5f1d17c60f6ff115c9c44cc0b6f1df6, which I've checked against CMake 2.8.11.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b71d90385..d9c0a1fbf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,6 +28,7 @@ INCLUDE(CheckLibraryExists)
INCLUDE(CheckFunctionExists)
INCLUDE(CheckSymbolExists)
INCLUDE(CheckStructHasMember)
+INCLUDE(CheckPrototypeDefinition) # Added in CMake 3.0
INCLUDE(AddCFlagIfSupported)
INCLUDE(FindPkgLibraries)
INCLUDE(FindThreads)