summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEdward Thomson <ethomson@edwardthomson.com>2021-11-06 16:38:57 -0400
committerEdward Thomson <ethomson@edwardthomson.com>2021-11-11 15:56:10 -0500
commit4d2a6839dc5b020b26ab8209952d95411eb34da5 (patch)
tree519819500d7ff17e2c223e4861458e0ba8366566 /CMakeLists.txt
parent7b527c12bc07d61fb6d2f0d7bb0b35815dbae49d (diff)
downloadlibgit2-4d2a6839dc5b020b26ab8209952d95411eb34da5.tar.gz
cmake: move fuzzer args to the fuzzer's cmake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 2 insertions, 15 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 46506590e..5421bd731 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -113,14 +113,6 @@ else()
# that uses CMAKE_CONFIGURATION_TYPES and not CMAKE_BUILD_TYPE
endif()
-IF(BUILD_FUZZERS AND NOT USE_STANDALONE_FUZZERS)
- # The actual sanitizer link target will be added when linking the fuzz
- # targets.
- set(CMAKE_REQUIRED_FLAGS "-fsanitize=fuzzer-no-link")
- add_c_flag(-fsanitize=fuzzer-no-link)
- unset(CMAKE_REQUIRED_FLAGS)
-endif()
-
#
# Subdirectories
#
@@ -137,13 +129,8 @@ if(BUILD_EXAMPLES)
endif()
if(BUILD_FUZZERS)
- if(NOT USE_STANDALONE_FUZZERS)
- if(BUILD_EXAMPLES)
- message(FATAL_ERROR "Cannot build the fuzzer targets and the examples together")
- endif()
- if(BUILD_TESTS)
- message(FATAL_ERROR "Cannot build the fuzzer targets and the tests together")
- endif()
+ if((BUILD_TESTS OR BUILD_EXAMPLES) AND NOT USE_STANDALONE_FUZZERS)
+ message(FATAL_ERROR "Cannot build the fuzzer and the tests or examples together")
endif()
add_subdirectory(fuzzers)
endif()