summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPatrick Steinhardt <ps@pks.im>2018-11-29 07:21:41 +0100
committerGitHub <noreply@github.com>2018-11-29 07:21:41 +0100
commit487233fa88c7f5680878578326a2f935befc89d4 (patch)
treef7f1f0dc6da8381f400d3166b3e3dc6589ade42c /CMakeLists.txt
parenta904fc6d12ffc20aa1a238a78000921494222e89 (diff)
parentffe39babe515dd60cad49d2e66b739661800c74f (diff)
downloadlibgit2-487233fa88c7f5680878578326a2f935befc89d4.tar.gz
Merge pull request #4895 from pks-t/pks/unused-warnings
Unused function warnings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 513dd7518..8dd2992ca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -228,8 +228,8 @@ ELSE ()
ENABLE_WARNINGS(strict-prototypes)
ENABLE_WARNINGS(declaration-after-statement)
ENABLE_WARNINGS(shift-count-overflow)
- DISABLE_WARNINGS(unused-const-variable)
- DISABLE_WARNINGS(unused-function)
+ ENABLE_WARNINGS(unused-const-variable)
+ ENABLE_WARNINGS(unused-function)
ENABLE_WARNINGS(format)
ENABLE_WARNINGS(format-security)
ENABLE_WARNINGS(int-conversion)