summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEdward Thomson <ethomson@edwardthomson.com>2022-06-14 22:29:10 -0400
committerEdward Thomson <ethomson@edwardthomson.com>2022-06-20 17:12:49 -0400
commit6c57bac6b18f6a30e1a8c8272a8dc367f202aa88 (patch)
tree776f5f9023d3b0076229d1750ff6cedbcd54ef7a /CMakeLists.txt
parentd103620158bb5aca73bc0dad8a230ceda417ab47 (diff)
downloadlibgit2-6c57bac6b18f6a30e1a8c8272a8dc367f202aa88.tar.gz
sha256: make sha256 an experimental optional feature
libgit2 can be built with optional, experimental sha256 support. This allows consumers to begin testing and providing feedback for our sha256 support while we continue to develop it, and allows us to make API breaking changes while we iterate on a final sha256 implementation. The results will be `git2-experimental.dll` and installed as `git2-experimental.h` to avoid confusion with a production libgit2.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2b5a2842c..cf3b62246 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,6 +15,9 @@ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${PROJECT_SOURCE_DIR}/cmake")
# Build options
#
+# Experimental features
+option(EXPERIMENTAL_SHA256 "Enable experimental SHA256 support (for R&D/testing)" OFF)
+
# Optional subsystems
option(BUILD_SHARED_LIBS "Build Shared Library (OFF for Static)" ON)
option(BUILD_TESTS "Build Tests using the Clar suite" ON)
@@ -107,6 +110,7 @@ include(IdeSplitSources)
include(FeatureSummary)
include(EnableWarnings)
include(DefaultCFlags)
+include(ExperimentalFeatures)
#