summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEdward Thomson <ethomson@github.com>2016-02-28 11:31:10 -0500
committerEdward Thomson <ethomson@github.com>2016-02-28 11:31:10 -0500
commit6cc4bac894281d3e80e1861c1ccb0e234cbd9bb0 (patch)
tree117e48da65c13ac7b89454f34417951d714ea33d /CMakeLists.txt
parent9f4e7c84904030ecc7d14637fa8c51bac087fedf (diff)
parent93e16642280ab637f8688b8c2146b11f95f98325 (diff)
downloadlibgit2-6cc4bac894281d3e80e1861c1ccb0e234cbd9bb0.tar.gz
Merge pull request #3577 from rossdylan/rossdylan/pooldebug
Add a new build flag to disable the pool allocator
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6a7dac21d..931b06459 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,6 +41,11 @@ OPTION( USE_SSH "Link with libssh to enable SSH support" ON )
OPTION( USE_GSSAPI "Link with libgssapi for SPNEGO auth" OFF )
OPTION( VALGRIND "Configure build for valgrind" OFF )
OPTION( CURL "User curl for HTTP if available" ON)
+OPTION( DEBUG_POOL "Enable debug pool allocator" OFF )
+
+IF(DEBUG_POOL)
+ ADD_DEFINITIONS(-DGIT_DEBUG_POOL)
+ENDIF()
IF(${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
SET( USE_ICONV ON )