summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Pettersson <boretrk@hotmail.com>2021-08-08 13:22:53 +0200
committerPeter Pettersson <boretrk@hotmail.com>2021-08-08 13:26:24 +0200
commite96fc0283aea9afd02f64bdcb26613422e74dc3a (patch)
tree6eb38e100ef9d7b098ed42ba27d34938cac0dc9d /CMakeLists.txt
parente65229ee972c113413eeca77853213352129bd47 (diff)
downloadlibgit2-e96fc0283aea9afd02f64bdcb26613422e74dc3a.tar.gz
tests: optional test for p_open() with empty path segments
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ff3411928..937503829 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -51,6 +51,7 @@ OPTION(USE_STANDALONE_FUZZERS "Enable standalone fuzzers (compatible with gcc)"
OPTION(USE_LEAK_CHECKER "Run tests with leak checker" OFF)
OPTION(DEBUG_POOL "Enable debug pool allocator" OFF)
OPTION(DEBUG_STRICT_ALLOC "Enable strict allocator behavior" OFF)
+OPTION(DEBUG_STRICT_OPEN "Enable path validation in open" OFF)
OPTION(ENABLE_WERROR "Enable compilation with -Werror" OFF)
OPTION(USE_BUNDLED_ZLIB "Use the bundled version of zlib. Can be set to one of Bundled(ON)/Chromium. The Chromium option requires a x86_64 processor with SSE4.2 and CLMUL" OFF)
SET(USE_HTTP_PARSER "" CACHE STRING "Specifies the HTTP Parser implementation; either system or builtin.")