summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCarlos Martín Nieto <carlos@cmartin.tk>2011-08-12 23:57:44 +0200
committerCarlos Martín Nieto <carlos@cmartin.tk>2011-08-12 23:57:44 +0200
commit4fd486e0c226963cffe069b2fbb3127eb0354775 (patch)
treeed203043233c9cfd8fc12645f7deec399ae8f1cc /CMakeLists.txt
parentb2e60e4eb5efc2d8ab78371ecd85e8a1f482134d (diff)
downloadlibgit2-4fd486e0c226963cffe069b2fbb3127eb0354775.tar.gz
Really fix pkg-config
Without the @ONLY option, CONFIGURE_FILE would replace the variables that are meant to be used to pkg-config at configure time. Signed-off-by: Carlos Martín Nieto <carlos@cmartin.tk>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4c7bb0263..ffb53cd84 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -103,7 +103,7 @@ ENDIF ()
TARGET_LINK_LIBRARIES(git2 ${CMAKE_THREAD_LIBS_INIT})
SET_TARGET_PROPERTIES(git2 PROPERTIES VERSION ${LIBGIT2_VERSION_STRING})
SET_TARGET_PROPERTIES(git2 PROPERTIES SOVERSION ${LIBGIT2_VERSION_MAJOR})
-CONFIGURE_FILE(libgit2.pc.in libgit2.pc)
+CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/libgit2.pc.in ${CMAKE_CURRENT_BINARY_DIR}/libgit2.pc @ONLY)
# Install
INSTALL(TARGETS git2
@@ -111,7 +111,7 @@ INSTALL(TARGETS git2
LIBRARY DESTINATION ${INSTALL_LIB}
ARCHIVE DESTINATION ${INSTALL_LIB}
)
-INSTALL(FILES ${CMAKE_BINARY_DIR}/libgit2.pc DESTINATION ${INSTALL_LIB}/pkgconfig )
+INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/libgit2.pc DESTINATION ${INSTALL_LIB}/pkgconfig )
INSTALL(DIRECTORY include/git2 DESTINATION ${INSTALL_INC} )
INSTALL(FILES include/git2.h DESTINATION ${INSTALL_INC} )