summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVicent Marti <tanoku@gmail.com>2013-11-05 22:08:02 +0100
committerVicent Marti <tanoku@gmail.com>2013-11-05 22:08:38 +0100
commit73291aff6e695b13fa738c03cd344491c9ad24b3 (patch)
treeaf82dc57718f934fc3effeeb18f2843f51ea431e /CMakeLists.txt
parenta8baf4b16058846eb56afaa1faea04fa41c4a4d4 (diff)
downloadlibgit2-73291aff6e695b13fa738c03cd344491c9ad24b3.tar.gz
cmake: Add `USE_SSH` option
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a14abae0a..2440ed0b8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,6 +32,8 @@ OPTION( LIBGIT2_FILENAME "Name of the produced binary" OFF )
OPTION( ANDROID "Build for android NDK" OFF )
OPTION( USE_ICONV "Link with and use iconv library" OFF )
+OPTION( USE_SSH "Link with libssh to enable SSH support" ON )
+
IF(APPLE)
SET( USE_ICONV ON )
ENDIF()
@@ -186,7 +188,7 @@ ELSE()
FILE(GLOB SRC_ZLIB deps/zlib/*.c deps/zlib/*.h)
ENDIF()
-IF (NOT MINGW)
+IF (USE_SSH AND NOT MINGW)
FIND_PACKAGE(LIBSSH2 QUIET)
ENDIF()
IF (LIBSSH2_FOUND)