summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRussell Belfer <rb@github.com>2014-04-28 14:04:29 -0700
committerRussell Belfer <rb@github.com>2014-05-02 09:21:32 -0700
commit240f4af321612a0fe4cf01aed75a8cb44173feb8 (patch)
treed92455ee46456a2de161b1128b0555e9a6e43401 /CMakeLists.txt
parent6a1ca96e4193f79c16c6a71dd8b5d576acf22e91 (diff)
downloadlibgit2-240f4af321612a0fe4cf01aed75a8cb44173feb8.tar.gz
Add build option for diff internal statistics
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 884c9bcf1..83e03d6cd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,6 +37,7 @@ OPTION( ANDROID "Build for android NDK" OFF )
OPTION( USE_ICONV "Link with and use iconv library" OFF )
OPTION( USE_SSH "Link with libssh to enable SSH support" ON )
OPTION( VALGRIND "Configure build for valgrind" OFF )
+OPTION( PERF_STATS "Internally track performance data" OFF )
IF(${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
SET( USE_ICONV ON )
@@ -352,6 +353,10 @@ IF (THREADSAFE)
ADD_DEFINITIONS(-DGIT_THREADS)
ENDIF()
+IF (PERF_STATS)
+ ADD_DEFINITIONS(-DGIT_PERF)
+ENDIF()
+
ADD_DEFINITIONS(-D_FILE_OFFSET_BITS=64)
# Collect sourcefiles