summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMiha <miha.ravselj@ib-caddy.si>2014-02-25 11:56:11 +0100
committerMiha <miha.ravselj@ib-caddy.si>2014-02-25 11:56:11 +0100
commit300f44125a5abb00f6185babc9bb828aec556015 (patch)
treea33c83a50371201aa980d1eec45f351c8ac9d261 /CMakeLists.txt
parentcb81c3a764447ceb2cd693935bf970138ea60ccc (diff)
downloadlibgit2-300f44125a5abb00f6185babc9bb828aec556015.tar.gz
- BUGFIX #2133 (@fourplusone) in smart_protocol.c
- added MSVC cmake definitions to disable warnings - general.c is rewritten so it is ansi-c compatible and compiles ok on microsoft windows - some MSVC reported warning fixes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d6b327503..27cf1a558 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,7 +21,8 @@ INCLUDE(CheckLibraryExists)
# Build options
#
-OPTION( SONAME "Set the (SO)VERSION of the target" ON )
+OPTION( SONAME
+ "Set the (SO)VERSION of the target" ON )
OPTION( BUILD_SHARED_LIBS "Build Shared Library (OFF for Static)" ON )
OPTION( THREADSAFE "Build libgit2 as threadsafe" OFF )
OPTION( BUILD_CLAR "Build Tests using the Clar suite" ON )
@@ -57,6 +58,10 @@ IF(MSVC)
# By default, libgit2 is built with WinHTTP. To use the built-in
# HTTP transport, invoke CMake with the "-DWINHTTP=OFF" argument.
OPTION( WINHTTP "Use Win32 WinHTTP routines" ON )
+
+ ADD_DEFINITIONS(-D_SCL_SECURE_NO_WARNINGS)
+ ADD_DEFINITIONS(-D_CRT_SECURE_NO_DEPRECATE)
+ ADD_DEFINITIONS(-D_CRT_NONSTDC_NO_DEPRECATE)
ENDIF()
# This variable will contain the libraries we need to put into