summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVicent Martí <vicent@github.com>2013-11-10 07:31:21 -0800
committerVicent Martí <vicent@github.com>2013-11-10 07:31:21 -0800
commit0df96f2b05f45e62047fc592ded37c0ef18ec27b (patch)
treeabbfd0757d065fda064f5a2276df783b7b535319 /CMakeLists.txt
parent4cb3c7abe1a56ef93d2e0078ad86d09aed0cccce (diff)
parent79c443425b1b3d67e8180663c6e80793b587c888 (diff)
downloadlibgit2-0df96f2b05f45e62047fc592ded37c0ef18ec27b.tar.gz
Merge pull request #1936 from libgit2/better-url-parsing
Streamline url-parsing logic.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2440ed0b8..271af690c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -128,6 +128,8 @@ INCLUDE_DIRECTORIES(src include)
IF (WIN32 AND WINHTTP AND NOT MINGW)
ADD_DEFINITIONS(-DGIT_WINHTTP)
+ INCLUDE_DIRECTORIES(deps/http-parser)
+ FILE(GLOB SRC_HTTP deps/http-parser/*.c deps/http-parser/*.h)
ELSE ()
IF (NOT AMIGA)
FIND_PACKAGE(OpenSSL)