summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorEdward Thomson <ethomson@edwardthomson.com>2021-12-12 14:25:25 -0500
committerEdward Thomson <ethomson@edwardthomson.com>2022-01-22 19:20:11 -0500
commiteb94f70a66a8797ac2b255a14254506dcc03173c (patch)
tree3716fc2c260681ab016bc961d229373840c14471 /src/CMakeLists.txt
parentdae714df3f624ce007cec59839f86b0f4d07a357 (diff)
downloadlibgit2-eb94f70a66a8797ac2b255a14254506dcc03173c.tar.gz
sha: add sha256 algorithm
Add support for a SHA256 hash algorithm, and add the "builtin" SHA256 hash engine (from RFC 6234).
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 51e915b35..7338932cb 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -110,7 +110,11 @@ elseif(USE_SHA1 STREQUAL "Win32")
file(GLOB SRC_SHA1 hash/win32.*)
endif()
-target_sources(git2internal PRIVATE ${SRC_SHA1} "hash/sha.h")
+if(USE_SHA256 STREQUAL "Builtin")
+ file(GLOB SRC_SHA256 hash/builtin.* hash/rfc6234/*)
+endif()
+
+target_sources(git2internal PRIVATE ${SRC_SHA1} ${SRC_SHA256} "hash/sha.h")
# Optional external dependency: ntlmclient
if(USE_NTLMCLIENT)