summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2019-05-02 19:01:38 +0100
committerSimon McVittie <smcv@collabora.com>2019-05-02 19:14:50 +0100
commit04c11c7390c5e044aa0079c3b5b5e7a3c8b7f577 (patch)
treef7bb0adeb404f0183f264fd0ae79b5a9ae131e6c /tests/meson.build
parent5920f9f3fc3c1c0fb029296b91938d103fb7886a (diff)
downloadlibglnx-04c11c7390c5e044aa0079c3b5b5e7a3c8b7f577.tar.gz
Run the fdio test in its own temporary directory
The temporary directory will be deleted on success, but will remain intact on failure. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/meson.build b/tests/meson.build
index d3eddf0..de141c5 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -9,7 +9,11 @@ test_names = [
foreach test_name : test_names
exe = executable(test_name,
- ['test-libglnx-' + test_name + '.c', 'libglnx-testlib.h'],
+ [
+ 'libglnx-testlib.c',
+ 'libglnx-testlib.h',
+ 'test-libglnx-' + test_name + '.c',
+ ],
dependencies: [
libglnx_dep,
libglnx_deps,