summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2019-10-11 11:57:33 +0000
committerColin Walters <walters@verbum.org>2019-10-11 11:57:33 +0000
commit41ecc5441f573b9b06d8dd360313e78047c11c45 (patch)
tree51ccb545b85b5f6c366bac3fe46c306cb4dfa967 /tests/meson.build
parent2eeb8a7512be6755307cb21ccde4384016c6771f (diff)
parent4fca08e26808824b1f2a9866968eb245ce1da603 (diff)
downloadlibglnx-41ecc5441f573b9b06d8dd360313e78047c11c45.tar.gz
Merge branch 'meson-older-compilers' into 'master'
Add Meson build system and Gitlab-CI See merge request GNOME/libglnx!8
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
new file mode 100644
index 0000000..de141c5
--- /dev/null
+++ b/tests/meson.build
@@ -0,0 +1,23 @@
+
+test_names = [
+ 'errors',
+ 'fdio',
+ 'macros',
+ 'shutil',
+ 'xattrs',
+]
+
+foreach test_name : test_names
+ exe = executable(test_name,
+ [
+ 'libglnx-testlib.c',
+ 'libglnx-testlib.h',
+ 'test-libglnx-' + test_name + '.c',
+ ],
+ dependencies: [
+ libglnx_dep,
+ libglnx_deps,
+ ],
+ )
+ test(test_name, exe)
+endforeach