summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
new file mode 100644
index 0000000..de141c5
--- /dev/null
+++ b/tests/meson.build
@@ -0,0 +1,23 @@
+
+test_names = [
+ 'errors',
+ 'fdio',
+ 'macros',
+ 'shutil',
+ 'xattrs',
+]
+
+foreach test_name : test_names
+ exe = executable(test_name,
+ [
+ 'libglnx-testlib.c',
+ 'libglnx-testlib.h',
+ 'test-libglnx-' + test_name + '.c',
+ ],
+ dependencies: [
+ libglnx_dep,
+ libglnx_deps,
+ ],
+ )
+ test(test_name, exe)
+endforeach