summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2015-04-10 10:52:24 +0200
committerWerner Koch <wk@gnupg.org>2015-04-10 10:53:58 +0200
commiteaec10f48803ee2232d1c1515fbe8f485c1e84b0 (patch)
tree3338689dfec07ceabdd2b36ba3f072765263bff6 /src/Makefile.am
parent56feff58d4fab92701ae77a1004af820b85e7f6c (diff)
downloadlibgpg-error-eaec10f48803ee2232d1c1515fbe8f485c1e84b0.tar.gz
w32: Remove compiler warnings.
* src/Makefile.am (pre_mkheader_cmds): Avoid make diagnostic about failed but ignored command. This confuses Emacs' compiler job parser. * tests/t-lock.c [W32]: Include time.h. * src/init.c: Reorganize Windows only code. (wchar_to_utf8, utf8_to_wchar): Remove unused functions. (_gpg_err_set_errno): Use only one copy for all platforms. -- Note that there is a still a problem for W64 pertaining to the use of an int to store a HANDLE. This will be fixed when we add a full abstraction layer for Windows file objects.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f847a80..e038d7f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -276,7 +276,8 @@ parts_of_gpg_error_h = \
# If we are cross-compiling or building on Windows we better make sure
# that no stale native lock include file will be found by mkheader.
if FORCE_USE_SYSCFG
-pre_mkheader_cmds = -rm lock-obj-pub.native.h 2>/dev/null
+pre_mkheader_cmds = if test -f lock-obj-pub.native.h; \
+ then rm lock-obj-pub.native.h; fi
else
pre_mkheader_cmds = :
parts_of_gpg_error_h += ./lock-obj-pub.native.h