summaryrefslogtreecommitdiff
path: root/camlibs/mustek/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'camlibs/mustek/Makefile.am')
-rw-r--r--camlibs/mustek/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/camlibs/mustek/Makefile.am b/camlibs/mustek/Makefile.am
index 047c7f80b..17b8ed46f 100644
--- a/camlibs/mustek/Makefile.am
+++ b/camlibs/mustek/Makefile.am
@@ -1,8 +1,10 @@
-camlib_LTLIBRARIES = libgphoto2_mustek.la
+camlib_LTLIBRARIES = mustek.la
EXTRA_DIST = AUTHOR
-libgphoto2_mustek_la_SOURCES = mdc800.c core.c image.c io.c rs232.c usb.c core.h image.h io.h mdc800_spec.h print.h rs232.h usb.h
-
-libgphoto2_mustek_la_LIBADD = $(top_builddir)/libgphoto2/libgphoto2.la
-libgphoto2_mustek_la_LDFLAGS = -module -avoid-version
+mustek_la_SOURCES = mdc800.c core.c image.c \
+ io.c rs232.c usb.c core.h image.h \
+ io.h mdc800_spec.h print.h rs232.h usb.h
+mustek_la_LDFLAGS = -module -no-undefined -avoid-version -export-dynamic \
+ -export-symbols $(top_srcdir)/camlibs/camlib.sym
+mustek_la_LIBADD = $(top_builddir)/libgphoto2/libgphoto2.la