summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorChoe Hwanjin <choe.hwanjin@gmail.com>2008-02-24 02:29:23 +0900
committerChoe Hwanjin <choe.hwanjin@gmail.com>2008-02-24 02:29:23 +0900
commit234795cf54ad7ab9376d204720e4f9ab3a851e99 (patch)
tree0b82311c352f21391928882d7c2d16af03ba61d4 /tools/Makefile.am
parentebb1debbbac572af8e0655b2071185e138ead403 (diff)
downloadlibhangul-234795cf54ad7ab9376d204720e4f9ab3a851e99.tar.gz
한자 사전 파일을 바이너리 형태로 사용하는 기능 구현:
* 내부적으로 mmap을 이용하여 로딩, 메모리 사용량을 줄임 * txt 버젼은 vector로 구현, 더이상 slist를 사용하지 않음 * hanja.txt파일을 hanja.bin 형태로 변환하여 사용함 * 파일 포맷 변환을 위한 API, hanja_table_txt_to_bin() 추가 * tools 디렉토리 추가 * 파일 포맷 변환을 위해 hanjac라는 도구를 제공 * 기본 한자 사전 파일을 hanja.txt에서 hanja.bin으로 변경 새로운 api 추가 * hanja_list_get_nth_key() git-svn-id: http://kldp.net/svn/hangul/libhangul/trunk@158 8f00fcd2-89fc-0310-932e-b01be5b65e01
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
new file mode 100644
index 0000000..fd0bc9b
--- /dev/null
+++ b/tools/Makefile.am
@@ -0,0 +1,6 @@
+
+bin_PROGRAMS = hanjac
+
+hanjac_CFLAGS =
+hanjac_SOURCES = hanjac.c
+hanjac_LDADD = ../hangul/libhangul.la