summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 8 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cf41f1b8..765602c0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -296,7 +296,8 @@ else()
set(ICAL_ALLOW_EMPTY_PROPERTIES 0)
endif()
-option(USE_BUILTIN_TZDATA "build using our own timezone data, else use the system timezone data on non-Windows systems. ALWAYS true on Windows.")
+option(USE_BUILTIN_TZDATA "(Careful) Build using libical's built-in timezone data, else use the system timezone data on non-Windows systems. ALWAYS true on Windows. Non-Windows users should know what they're doing if they choose not to use system provided timezone data. The libical project does not guarantee that the built-in timezone data is up-to-date.")
+mark_as_advanced(USE_BUILTIN_TZDATA)
if(USE_BUILTIN_TZDATA)
set(USE_BUILTIN_TZDATA 1)
else()
@@ -505,7 +506,8 @@ if("${CMAKE_CXX_COMPILER_ID}" MATCHES "Clang")
endif()
################ Developer Options #####################
-option(ABI_DUMPER "Build for abi-dumper." False)
+option(ABI_DUMPER "(Developer-only) Build for abi-dumper." False)
+mark_as_advanced(ABI_DUMPER)
if(ABI_DUMPER)
if(CMAKE_COMPILER_IS_GNUCC)
set(CMAKE_C_FLAGS "-g -Og")
@@ -516,7 +518,8 @@ if(ABI_DUMPER)
endif()
endif()
-option(ADDRESS_SANITIZER "Build with the address sanitizer." False)
+option(ADDRESS_SANITIZER "(Developer-only) Build with the address sanitizer." False)
+mark_as_advanced(ADDRESS_SANITIZER)
if(ADDRESS_SANITIZER)
if(CMAKE_COMPILER_IS_GNUCC OR "${CMAKE_C_COMPILER_ID}" MATCHES "Clang")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fsanitize=address -g")
@@ -541,7 +544,8 @@ if(ADDRESS_SANITIZER)
endif()
endif()
-option(THREAD_SANITIZER "Build with the thread sanitizer." False)
+option(THREAD_SANITIZER "(Developer-only) Build with the thread sanitizer." False)
+mark_as_advanced(THREAD_SANITIZER)
if(THREAD_SANITIZER)
if(CMAKE_COMPILER_IS_GNUCC OR "${CMAKE_C_COMPILER_ID}" MATCHES "Clang")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fsanitize=thread -O1 -g")