summaryrefslogtreecommitdiff
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index c655d26..726c214 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -10,6 +10,7 @@ INCLUDES = \
libraries = \
$(top_builddir)/src/libmtp.la \
$(GLIB_LIBS) \
+ -ludev
$(NULL)
dbus_built_sources = mtp-dbus.c mtp-dbus.h
@@ -21,14 +22,12 @@ $(dbus_built_sources) : Makefile.am dbus-interface.xml
--c-namespace MTPD \
--c-generate-object-manager \
--generate-c-code mtp-dbus \
- --generate-docbook generated-docs \
- --generate-c-code mtp-dbus \
$(srcdir)/dbus-interface.xml \
$(NULL)
sbin_PROGRAMS = mtpd
-mtpd_SOURCES = mtpd.c udev_listener.c
+mtpd_SOURCES = mtpd.c udev_listener.c dbus_service.c mtp_manager.c
mtpd_LDADD = $(libraries)
# D-BUS service file