summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKai Vehmanen <first.surname@nokia.com>2007-06-19 08:11:00 +0000
committerKai Vehmanen <first.surname@nokia.com>2007-06-19 08:11:00 +0000
commit48a92df591ec6e8d2f2eb8286e6f4af7d588646f (patch)
tree4bc803ed438204c41d74c14f7d2f07ea5cc81f2d /Makefile.am
parentf9852c9d77fdb6991a2726f60a975dd2a8172d64 (diff)
downloadlibnice-48a92df591ec6e8d2f2eb8286e6f4af7d588646f.tar.gz
Top-level makefile update: checks for more system headers, C99 compiler check. Added definition of dummy NICEAPI_EXPORT.
darcs-hash:20070619081134-77cd4-7deeaa78d59feca05595dd4f7cbd19d94f2e6ccd.gz
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 26 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index f235a93..57625e1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,7 +8,7 @@
include common.mk
-SUBDIRS = \
+ALWAYS_SUBDIRS = \
address \
local \
stun \
@@ -17,14 +17,25 @@ SUBDIRS = \
random \
agent \
nice
+SUBDIRS = $(ALWAYS_SUBDIRS)
if WITH_GSTREAMER
SUBDIRS += gst
endif
-DIST_SUBDIRS = $(SUBDIRS) gst
+DIST_SUBDIRS = $(ALWAYS_SUBDIRS) gst
+DISTCHECK_CONFIGURE_FLAGS = --disable-assert --without-gstreamer
-EXTRA_DIST = scripts common.mk
+EXTRA_DIST = \
+ common.mk \
+ Doxyfile.in \
+ scripts/lcov.mk \
+ scripts/lcov.sh \
+ scripts/valgrind.sh
+
+dist_check_SCRIPTS = \
+ scripts/check-symbols.sh \
+ scripts/make-symbol-list.sh
lcov:
find -name '*.gcda' -delete
@@ -43,4 +54,15 @@ lcov-report:
lcov -r lcov/lcov.info `cat lcov/lcov.remove` 2>/dev/null > lcov/lcov.info.clean
genhtml -o lcov lcov/lcov.info.clean
-.PHONY: lcov-report lcov
+Doxyfile: Doxyfile.in config.status
+ $(SHELL) ./config.status --file=$@
+
+doc: Doxyfile
+ $(DOXYGEN) $<
+
+CLEANFILES += Doxyfile
+
+clean-local:
+ rm -rf doc
+
+.PHONY: doc lcov-report lcov