summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPhilip Withnall <philip.withnall@collabora.co.uk>2015-05-08 10:13:39 +0100
committerPhilip Withnall <philip.withnall@collabora.co.uk>2015-05-08 10:13:39 +0100
commitd3a7b315ec708ac9ecb8df53bcc8d108016bd508 (patch)
tree26bb5e8b2b3a4db37021709e49d31f7916e47421 /Makefile.am
parent6a8c63219c632c27707267b6510dca096c6fd511 (diff)
downloadlibnice-d3a7b315ec708ac9ecb8df53bcc8d108016bd508.tar.gz
build: Auto-generate win32 .def file from libnice.sym
We’ve neglected to manually update this file once too often — it’s been out of date for important new symbols (for example, nice_agent_get_io_stream()) since at least 0.1.11. Since the format is a simple extension of libnice.sym, we might as well automatically generate it at dist time.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 432a14d..21402e8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,6 +33,7 @@ EXTRA_DIST = \
scripts/lcov.sh \
scripts/valgrind.sh \
win32 \
+ win32/vs9/libnice.def \
m4/introspection.m4
MAINTAINERCLEANFILES = ar-lib
@@ -41,6 +42,22 @@ dist_check_SCRIPTS = \
scripts/check-symbols.sh \
scripts/make-symbol-list.sh
+# Generate the win32 DLL symbol export file.
+# The stun_*() symbols at the end have historically been exported on Windows
+# but not Linux, for no particular reason. They can’t be removed without
+# breaking ABI. FIXME: Remove them when we next break ABI.
+win32/vs9/libnice.def: nice/libnice.sym
+ $(AM_V_GEN)(echo "LIBRARY libnice"; \
+ echo ""; \
+ echo "EXPORTS"; \
+ echo ""; \
+ cat $<; \
+ echo "stun_debug"; \
+ echo "stun_debug_bytes"; \
+ echo "stun_hash_creds") > $@
+
+CLEANFILES = win32/vs9/libnice.def
+
lcov:
find -name '*.gcda' -delete
$(MAKE) $(AM_MAKEFLAGS) check