summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPhilip Withnall <philip.withnall@collabora.co.uk>2014-06-30 17:30:21 +0100
committerOlivier CrĂȘte <olivier.crete@collabora.com>2014-07-07 15:47:02 -0400
commit0388646bdba5f91bb6bb509f5a1c6e9e3f068555 (patch)
tree864c997fcfe9e1730972ed839d238c423168dd55 /configure.ac
parent9981969d7dc14d6eb67389b56c37194938841c61 (diff)
downloadlibnice-0388646bdba5f91bb6bb509f5a1c6e9e3f068555.tar.gz
build: Add GObject introspection support
This bumps our autoconf requirement to 2.62 (from 2.59c) and disables automake portability warnings. It does not introduce a hard dependency on gobject-introspection; but if available, it requires version 1.30.0. Support can be enabled with --enable-introspection, and is required to make distcheck. The generated introspection file has not been checked thoroughly, and may expose internal symbols. A lot of new annotations are needed to make many of the symbols usable.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 124c9ea..b14ff22 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
-AC_PREREQ(2.59c)
+AC_PREREQ(2.62)
dnl Always compile with -Wall; if --enable-compile-warnings=error is passed,
dnl also use -Werror. git and pre-releases default to -Werror
@@ -12,7 +12,7 @@ AC_CANONICAL_TARGET
AC_CONFIG_SRCDIR([agent/agent.c])
AC_CONFIG_HEADERS([config.h])
-AM_INIT_AUTOMAKE([1.12 -Wall])
+AM_INIT_AUTOMAKE([1.12 -Wall -Wno-portability])
AC_CONFIG_FILES([
Makefile
@@ -314,6 +314,10 @@ GTK_DOC_CHECK(1.9)
],[
AM_CONDITIONAL([ENABLE_GTK_DOC], false)
])
+
+# GObject introspection
+GOBJECT_INTROSPECTION_CHECK([1.30.0])
+
AC_CONFIG_MACRO_DIR(m4)
AC_OUTPUT