summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPhilip Withnall <philip.withnall@collabora.co.uk>2013-10-28 13:33:57 +0000
committerOlivier CrĂȘte <olivier.crete@collabora.com>2013-10-29 13:47:31 +0000
commit6c900953600cd955a84d4c20f573a0c29e76100e (patch)
treee7a6edc7ff0a4dbdab24ac9f202317211179398c /configure.ac
parent1432e9aec3a72c5d88d0a87e6865b19824065c52 (diff)
downloadlibnice-6c900953600cd955a84d4c20f573a0c29e76100e.tar.gz
build: Update configure.ac according to autoupdate
https://bugs.freedesktop.org/show_bug.cgi?id=70965
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 50683a0..6b05633 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,10 +3,10 @@ AC_PREREQ(2.59c)
dnl releases only do -Wall, cvs and prerelease does -Werror too
dnl use a three digit version number for releases, and four for cvs/prerelease
-AC_INIT(libnice, 0.1.4.1)
+AC_INIT([libnice],[0.1.4.1])
LIBNICE_RELEASE="no"
-AC_CANONICAL_SYSTEM
+AC_CANONICAL_TARGET
AC_CONFIG_SRCDIR([agent/agent.c])
AC_CONFIG_HEADER([config.h])
@@ -56,7 +56,7 @@ m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])],
AC_PROG_CC
AM_PROG_AR
AC_USE_SYSTEM_EXTENSIONS
-AC_PROG_LIBTOOL
+LT_INIT
# Check Operating System
AC_MSG_CHECKING([operating system])
@@ -116,12 +116,12 @@ PKG_CHECK_MODULES(GLIB, [dnl
])
AC_ARG_WITH(gstreamer,
- AC_HELP_STRING([--with-gstreamer], [build GStreamer plugin]),
+ AS_HELP_STRING([--with-gstreamer],[build GStreamer plugin]),
[with_gstreamer=${withval}],
[with_gstreamer=auto])
AC_ARG_WITH(gstreamer-0.10,
- AC_HELP_STRING([--with-gstreamer-0.10], [build GStreamer 0.10 plugin]),
+ AS_HELP_STRING([--with-gstreamer-0.10],[build GStreamer 0.10 plugin]),
[with_gstreamer010=${withval}],
[with_gstreamer010=auto])
@@ -174,7 +174,7 @@ AM_CONDITIONAL(WITH_GSTREAMER010, test "$with_gstreamer010" = yes)
GUPNP_IGD_REQUIRED=0.1.2
AC_ARG_ENABLE([gupnp],
- AC_HELP_STRING([--disable-gupnp], [Disable GUPnP IGD support]),
+ AS_HELP_STRING([--disable-gupnp],[Disable GUPnP IGD support]),
[case "${enableval}" in
yes) WANT_GUPNP=yes ;;
no) WANT_GUPNP=no ;;
@@ -189,7 +189,7 @@ if test "x$WANT_GUPNP" != "xno"; then
[ HAVE_GUPNP=no ])
fi
if test "x$WANT_GUPNP" = "xyes" && test "x$HAVE_GUPNP" = "xno"; then
- AC_ERROR([Requested GUPnP IGD, but it is not available])
+ AC_MSG_ERROR(Requested GUPnP IGD, but it is not available)
fi
if test "x$HAVE_GUPNP" = "xyes"; then