summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOlivier CrĂȘte <olivier.crete@collabora.com>2014-07-23 22:36:46 +0100
committerOlivier CrĂȘte <olivier.crete@collabora.com>2014-07-24 10:40:19 +0100
commit73081e568aef158b84187c8bd1c43ab228ec2f78 (patch)
treee3ce091f1cb365e350d3a099308e8b04bebe073f /configure.ac
parent33be596f25191bc88ea19444a7b47873de98b34b (diff)
downloadlibnice-73081e568aef158b84187c8bd1c43ab228ec2f78.tar.gz
agent: Print libnice debug messages when setting G_MESSAGES_DEBUG appropriately
This way all the debug can be controlled from one place. Also disable -Wsuggest-attribute=format with -Werror because gcc 4.8.3 erroneously suggested it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3041dd8..054462a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -159,6 +159,7 @@ AS_IF([test "$enable_compile_warnings" = "maximum" -o \
])
AS_IF([test "x$enable_compile_warnings" = "xerror"],[
NICE_ADD_FLAG([-Werror])
+ NICE_ADD_FLAG([-Wno-suggest-attribute=format])
])
#